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There are many ways to analyze 
worksheet data, including sorting and 
filtering records. This chapter explains 
how to use a PivotTable to analyze data 
ranges. 

A PivotTable is usually the best way to 
summarize and analyze data ranges or 
tables. PivotTables are good for grouping 
or expanding levels of data, switching 
columns and rows (“pivoting” data), and 
filtering and sorting. They lend 
themselves particularly well to 
summarizing long lists of data that need 
to be summed.  

This chapter explains how to create 
PivotTables, modify their structure, and 
create PivotCharts that graphically 
illustrate PivotTables. 

Using Exercise Files 
This chapter suggests exercises to practice 
the topic of each lesson. There are two 
ways you may follow along with the 
exercise files: 

 Open the exercise file for a lesson, 
perform the lesson exercise, and close 
the exercise file. 

 Open the exercise file for a lesson, 
perform the lesson exercise, and keep 
the file open to perform the remaining 
lesson exercises for the chapter. 

The exercises are written so that you may 
“build upon them”, meaning the exercises 
in a chapter can be performed in 
succession from the first lesson to the last. 
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Creating a PivotTable 
To create a PivotTable, you need to decide which fields 
you want to include, how you want your PivotTable 
organized, and what types of calculations your PivotTable 
should perform.  

Don’t worry if PivotTables are confusing at first, they will 
make a lot more sense once you’ve actually created one. 

1. Select a cell in a data range.  

 Other Ways to Create a PivotTable: 
Select a cell in a table, click the Design tab on the 
Ribbon, and click the Summarize with Pivot 
button in the Tools group. 

2. Click the Insert tab on the Ribbon and click the 
PivotTable button in the Tables group. 

The Create PivotTable dialog box appears and a 
moving dashed line appears around the data range 
that Excel will use for the PivotTable. 

 Tip: The data range doesn’t have to be in the 
current workbook. Select the Use an external 
data source option to select data outside the 
workbook. 

3. If necessary, select the data range you want to 
analyze, including column labels. 

Next you need to decide if you want to display the 
PivotTable in a new worksheet or one that already 
exists in your workbook. 

4. Select where you want the PivotTable report to be 
placed. 

You can choose a new or existing worksheet. 

 Tip: If you select Existing Worksheet, click the 
Collapse Dialog button and select the worksheet 
and upper-left cell of the range where you want to 
put the PivotTable. 

5. Click OK. 

The Excel window changes to display the structure 
for a new PivotTable, along with the PivotTable Field 
List task pane. No data has been pulled into the 
PivotTable yet—you’ll need to use the task pane to 
tell Excel how you want to lay out the PivotTable. 

 Tips 

 You can change how the PivotTable Field List task 
pane looks. Click the button arrow near the top right 
corner of the task pane and select a layout option. 

 Exercise 

• Exercise File: TripSales10-1.xlsx 
• Exercise: Create a PivotTable on a new worksheet using 

the data from the Promotion Sales worksheet. 

Figure 10-1: The Create PivotTable dialog box. 

Figure 10-2: Creating a new PivotTable. 

Working with PivotTables 

PivotTable Field 
List task pane 
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Specifying PivotTable Data 
Once you’ve created your PivotTable, you have to specify 
the data you want to analyze. You’ll simply select the 
fields you want to display in the PivotTable Field List, 
then adjust the layout by dragging them between the 
desired report areas at the bottom of the task pane. You’re 
not going to understand how to do this unless you try it—
so let’s get started! 

Add fields 

1. Click the check boxes next to the fields you want to 
use as data in the PivotTable. 

By default, nonnumeric fields are added to the Row 
Labels area, numeric fields are added to the Values 
area, and OLAP date and time hierarchies are added 
to the Column Labels area. However, the fields can 
be rearranged to other areas. 

 Other Ways to Add Fields: 
Right-click a field name and select the layout area 
to which you want to add the field. Or, click and 
drag a field name into a layout section. 

Rearrange fields 

1. Click and drag fields between the areas in the task 
pane to reposition the PivotTable layout. 

The data and layout of the PivotTable change 
accordingly. 

 Tips 

 Drag a field between the Row Labels and Column 
Labels boxes to change the orientation of the 
PivotTable. 

 You can change PivotTable labels by typing a new 
label. 

 Exercise 

• Exercise File: TripSales10-2.xlsx 
• Exercise: Add the Office, Destination, and Tickets fields 

to the PivotTable.  
 Move the Office field to the Column Labels area.  
 Switch the positions of the Office and Destination fields. 

Figure 10-3: A PivotTable 
with data. 

1 The report filter area.  
Move a field to this area, then select the criteria by which 
you want to filter the PivotTable. 

2 The Column Label area. 

3 The Row Label area. 

4 The Results area.  
The results include data that from the fields in the column 
and row areas. Results are also filtered from the report 
filter area. 

Figure 10-4: This diagram illustrates how areas in the PivotTable Field List correspond to areas in the PivotTable report. 

Working with PivotTables 

The field section is where 
fields are added and 
removed in the PivotTable. 

The layout section is 
where fields are 
rearranged in the 
PivotTable. 
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Changing a PivotTable’s 
Calculation 
Besides adjusting the layout of your PivotTable data, you 
can also change how a PivotTable summarizes values. For 
example, you might want a PivotTable to display averages 
instead of totals. 

1. Make sure the cell pointer is located in the 
PivotTable.  

To change the calculation in a PivotTable, you need 
to change the value field settings. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Field Settings button in the 
Active Field group. 

The Value Field Settings dialog box appears, 
displaying the “Summarize by” tab. Here you can 
select calculation options including Sum, Count, 
Average, or Max, among others. 

3. Select the type of calculation you want to use to 
summarize the value data from the list. 

4. Click OK. 

The summarized value data in the PivotTable changes 
to using the new calculation. 

 Exercise 

• Exercise File: TripSales10-3.xlsx 
• Exercise: Change the calculation of the Tickets field from 

Sum to Max. 
 Change it back to Sum. 

Figure 10-5: The Value Field Settings dialog box. 

Working with PivotTables 
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Filtering and Sorting a 
PivotTable 
Much like you can with basic data ranges and tables in 
Excel, you can filter and sort data in a PivotTable. 

Filter a PivotTable 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 
PivotTable Tools on the Ribbon. 

2. Click the filter button for a row or column label. 

A list sorting and filtering options appears. The 
bottom area of the list displays criteria by which you 
can filter. 

 Other Ways to Select Filter Criteria: 
Click the Search box in the filter list and type the 
criteria by which you want to filter. The list 
displays criteria that match your search. 

3. At the bottom of the list, click the check boxes next 
to the fields you want to filter out to uncheck them.  

Fields with checkmarks next to them will remain, 
while those without checkmarks will be filtered out. 

4. Click OK. 

The PivotTable is updated. 

 Other Ways to Filter a PivotTable: 
Drag a field into the Report Filter area of the 
PivotTable Field List task pane. Click the field’s 
filter button above the PivotTable and select what 
you want to filter by. Or, click a filter button, 
point to Label Filters or Values Filters, and 
select a filtering option. 

Sort a PivotTable 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 
PivotTable Tools on the Ribbon. 

2. Click a filter button. 

Here you’ll see sort options at the top of the list, 
along with the filter options toward the bottom. 

3. Select a sort option. 

 Other Ways to Sort: 
Click the Options tab on the Ribbon. Click the 
button you want to use in the Sort group. 

 Exercise 

• Exercise File: TripSales10-4.xlsx 
• Exercise: Use the Row Labels filter button to display only 

records from Blaine. Clear the filter.  
 Try another way to filter: Add the Commission field to the 

Report Filter area of the PivotTable Field List and filter the 
PivotTable so only commissioned sales appear. Clear the 
filter.  

 Sort the PivotTable by Office (Row Labels) from Z to A, 
then sort again from A to Z. 

Figure 10-6: The PivotTable filtered to display only 
“Blaine” records. 

Figure 10-7: Adding a field to the Report Filter area. 

Working with PivotTables 

The filter button changes to make you aware 
that a filter has been applied. 

Drag fields 
you want to 
filter for to 
this area. 

Click the list arrow to choose 
how you want to filter the 
PivotTable. 
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Working with PivotTable 
Layout 
There are several options for altering the layout of your 
PivotTable and the PivotTable Field List task pane. 

Adjust PivotTable Field List layout 
You can change the layout of the PivotTable Field List 
makes it easier to work with. For example, you can 
display only the fields section if you have a long list of 
fields to choose from. Or, if you are done setting up the 
PivotTable, you can display only the area section.  

1. Select a cell in the PivotTable.  

The PivotTable Field List task pane appears.  

2. Click the layout button at the top of the PivotTable 
Field List task pane and select a layout option.  

You can choose to display only the fields section, 
only the report areas section, or both sections in 
different arrangements. The table below and to the 
right, PivotTable Field List Layout Options, is has 
more information about these arrangements. 

Show/Hide PivotTable elements 
You can change which elements are displayed in the 
PivotTable.  

1. Select a cell in the PivotTable.  

The Options and Design tabs appear under 
PivotTable Tools on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab. 

The Show/Hide group contains three buttons. By 
default, they are all shown in the PivotTable. 

 Field List: Show or hide the PivotTable Field List 
task pane. 

 +/- Buttons: Show or hide the +/- buttons that 
allow you to expand or collapse multi-level 
PivotTable items. 

 Field Headers: Show or hide column and row 
field headers. 

3. Click the button you want to use in the Show/Hide 
group. 

If the button is an orange color, the element is 
displayed in the PivotTable. If the button is not 
orange, the element is hidden. 

 Exercise 

• Exercise File: TripSales10-5.xlsx 
• Exercise: Change the layout of the PivotTable Field List 

so the field and area sections are side-by-side. Then change 
them back to stacked.  

 In the Show/Hide group of the Options tab on the Ribbon, 
hide the Field List and Field Headers. Show both again.  

 In the Layout group of the Design tab on the Ribbon, turn 
off the row and column grand totals. Enable them again.  

 Change the report layout to Tabular Form. 

Figure 10-8: Changing PivotTable Field List layout. 

Table 10-1: PivotTable Field List Layout Options 

 
This is the default layout. The fields are stacked above 
the areas. 

 
The fields appear side by side with the areas. This is 
useful if there is a long list of fields to choose from. 

 
Only the fields list is displayed. This is ideal if you 
only need to work with adding fields to the PivotTable 
report. 

 
Only the areas are displayed (2 by 2). This is ideal if 
the fields you want have been added and you want to 
work with the report’s layout. 

 
Only the areas are displayed (1 by 4). This is ideal if 
the fields you want have been added and you want to 
work with the report’s layout. 

Working with PivotTables 

Layout button 
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Layout group on the Design tab 
The Layout group on the Design tab allows you to change 
what elements appear on the PivotTable. 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 
PivotTable Tools on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 
Design tab. 

Here you can see the Layout group. It contains four 
buttons: 

 Subtotals: Click to show or hide subtotals, and to 
specify where to show them. 

 Grand Totals: Click to show or hide grand totals, 
and to specify whether they appear for rows, 
columns, or both. 

 Report Layout: Show the PivotTable in compact, 
outline, or tabular form. 

 Blank Rows: insert or remove a blank line 
between each grouped item in the PivotTable. 

3. Click the button you want to use in the Layout group. 

A list of options appears, depending on the button 
that was selected. 

4. Select an option from the list. 

The PivotTable layout is changed accordingly. 

Figure 10-9: The layout of the PivotTable in Tabular 
layout, and the Layout group on the Design tab. 

Working with PivotTables 
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Grouping PivotTable Items 
You can group PivotTable data in order to set it apart 
additional subsets of data. You can group most items, but 
dates are a common item to group. For example, you may 
want to group the information in the PivotTable by days, 
months, quarters, or years. 

Group dates or times 

1. Select the date or time field in the PivotTable.  

To select the field, click the name of the field in the 
PivotTable, such as the row or column header. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Group Field button in the 
Group group. 

The Grouping dialog box appears.  

3. Specify the starting and ending dates you want to 
group and the interval you want to group by. 

By default, the starting and ending dates are the first 
and last dates in the PivotTable. 

4. Click OK. 

The grouping is applied to the PivotTable report. 

 Tip: To group dates by weeks, select Days in the 
By area of the Grouping dialog box and enter 7 in 
the Number of days box. 

Group numeric items 

1. Select the numeric field in the PivotTable that 
contains the data you want to group by. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Group Field button in the 
Group group. 

The Grouping dialog box appears.  

3. Specify the starting and ending values you want to 
group and the interval you want to group by, then 
click OK. 

Group other selected items 
You can also group items that are not dates or numeric 
data, such as labels. 

1. Select the items in the PivotTable that you want to 
group. 

 Exercise 

• Exercise File: TripSales10-6.xlsx 
• Exercise: First, set up the PivotTable for grouping: 

Remove the Office field from the Row Labels area of the 
PivotTable Field List. Move the Destination field to the 
Row Labels area. Add the Date field to the Column Labels 
area.  
Select cell B3 and group the dates by month. Then ungroup 
the dates. 

Figure 10-10: Grouping the PivotTable dates by month. 

Working with PivotTables 

1. Select the field by which you want to group. This example 
happens to group by the Date field. 

2. Select the increment by which you want to group. This 
example will group the data so it is displayed by month, rather 
than by day. 

3. The data for each month is grouped together under one 
column, rather than being shown as separate days. 
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2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Group Selection button in 
the Group group. 

The items are grouped and collapse buttons appear so 
you can collapse or expand the group of data. 

 Tip: You can also use this method to group 
specific items in a field. 

Ungroup items 

1. Select the items in the PivotTable that you want to 
ungroup. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Ungroup button in the 
Group group. 

The items are ungrouped. 

Working with PivotTables 
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Updating a PivotTable 
If you make changes to the source data a PivotTable is 
based on, the PivotTable isn’t automatically updated. 
Instead you must manually refresh the PivotTable anytime 
you change its underlying source data. This lesson 
explains how to do that, as well as how to change the 
source of the data the PivotTable is based on. 

Refresh PivotTable data 
If you’ve made changes to the data what your PivotTable 
pulls from, you need to refresh the PivotTable to update it. 

1. Select a cell in the PivotTable.  

The PivotTable Tools are displayed on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Refresh button in the Data 
group. 

The PivotTable updates to include any changes to the 
source data. 

Change PivotTable data source 
You can easily change which data is used by the 
PivotTable. 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the Change Data Source 
button in the Data group. 

The Change PivotTable Data Source dialog box 
appears, along with the current data source—which 
has a moving dotted line around it. 

3. Select a new data range. 

4. Click OK. 

The PivotTable updates with the data from the new 
source range. 

 Exercise 

• Exercise File: TripSales10-7.xlsx 
• Exercise: View the Promotion Sales worksheet and change 

the value in cell G2 to 5. Return to the PivotTable on Sheet2 
and refresh the PivotTable. The data updates in C23. 

 Change the PivotTable data source so that it uses only the 
range A1:G4 on the Promotion Sales worksheet. 

Figure 10-11: The Data group on the Options tab. 

Figure 10-12: The Change PivotTable Data Source dialog 
box. 

Working with PivotTables 

Refresh button 
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Formatting a PivotTable 
You can quickly format a PivotTable with Excel’s built-in 
styles and style options. 

Apply a built-in style 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon. 

 2. Click the Design tab and select a style in the 
PivotTable Styles group. 

The PivotTable is formatted with the style you 
selected. 

 Tip: Click the More button in the PivotTable 
Styles group to display an expanded PivotTable 
Styles gallery. 

Work with style options 
Besides applying a style to the table, you can select 
PivotTable style options that allow you to adjust the 
format for a part of a PivotTable. For example, you can 
apply special formatting to row headers or make the 
columns banded. 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon. 

2. Click the Design tab and select an option in the 
PivotTable Style Options group. 

Here is a brief description of the style options you 
can select from in the PivotTable Style Options 
group: 

 Row/Column Headers: Displays special 
formatting for the first row or column of the 
PivotTable. 

 Banded Rows/Columns: Applies different 
formatting to alternate rows or columns. 

 Tips 

 Besides using the formatting options on the Design 
tab, you can format a PivotTable using general 
formatting commands found on the Home tab. 

 Exercise 

• Exercise File: TripSales10-8.xlsx 
• Exercise: Apply Pivot Style Medium 24 from the 

PivotTable Styles gallery.  
 Select the Banded Rows style option and deselect the 

Column Headers option. 

Figure 10-13: Selecting a built-in PivotTable style from the 
PivotTable Styles group. 

Figure 10-14: The PivotTable report with the updated style 
and style options. 

Working with PivotTables 

PivotTable 
style options Built-in styles 
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Creating a PivotChart 
A PivotChart is similar to an ordinary chart created in 
Excel, except that it plots a PivotTable’s information. Like 
PivotTable reports, PivotCharts are dynamic, which 
means you can change a PivotChart’s structure. 

1. Select a cell in the PivotTable.  

The PivotTable Tools are displayed on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 
Options tab and click the PivotChart button in the 
Tools group. 

The Insert Chart dialog box appears, displaying 
different types of charts. 

3. Select the type of chart you want to use and click 
OK. 

The chart appears in the worksheet with your 
PivotTable.  

 Tip: Click and drag the PivotChart’s border to 
move the chart around in the worksheet. 

4. Modify the chart using the PivotChart Filter Pane and 
the PivotTable tools. 

 Tips 

 If you modify the PivotTable, the PivotChart will 
change also. 

  More detailed information about modifying and 
formatting charts can be found in the “Creating and 
Working with Charts” chapter. 

 Exercise 

• Exercise File: TripSales10-9.xlsx 
• Exercise: Insert a Clustered Column PivotChart. 

Figure 10-15: The Insert Chart dialog box. 

Figure 10-16: A clustered column 
PivotChart. 

Working with PivotTables 

Use the PivotChart 
Filter pane to 
change the 
information 
displayed in the 
chart. 

Click the row or column filter 
buttons to filter the data 
shown in the PivotChart. 
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Using Slicers 
Slicers are a new feature in Excel 2010 that has been 
added in order to provide an easy way to filter PivotTable 
data. Slicers label the filters applied, with details, so you 
can easily understand the data that is displayed and 
filtered in the PivotTable report. 

Create a PivotTable Slicer 
Here’s how to create a slicer in an existing PivotTable. 

1. Click the PivotTable report to select it. 

The PivotTable Tools contextual tabs appear on the 
Ribbon. 

2. Click the Options tab under PivotTable Tools on the 
Ribbon and click the Insert Slicer button in the Sort 
& Filter group. 

The Insert Slicers dialog box appears. All the fields in 
your PivotTable are listed here; you decide which 
fields you want to filter by in the PivotTable. 

3. Click the check box of the PivotTable fields by which 
you wish to filter. 

Keep in mind that you’ll get a separate slicer for each 
field you select. 

4. Click OK. 

The slicer(s) appear above the PivotTable. You can 
move a slicer to another location on the worksheet, 
and resize it as needed. 

 Exercise 

• Exercise File: Slicers1.xlsx; Sheet1 
• Exercise: View the number of tickets the St. Cloud office 

sold to Boston, New York, and Washington D.C. 
 (Insert slicers for the Destination and Office fields. Select 

the St. Cloud button in the Office slicer. Select the Boston, 
New York, and Washington, D.C. buttons in the Destination 
slicer.) 

Figure 10-17: The Insert Slicers dialog box. 

Figure 10-18: The 
PivotTable with two slicers 
applied. 

Working with PivotTables 

Click a check box 
to use a slicer for 
the selected field. 
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Filter data using a slicer 
After you create a slicer, it appears on the worksheet 
alongside the PivotTable, in a layered display if you have 
more than one slicer.  

1. Click a button in a slicer. Press and hold the <Ctrl> 
or <Shift> keys to select multiple buttons. 

The button is selected, and the PivotTable data is 
filtered accordingly. 

 Tip: Simply click the button again to stop 
filtering out the selected data. 

Format a slicer 
You can change the appearance of a slicer to match the 
color scheme of your PivotTable. 

1. Click the slicer you want to format. 

The Slicer Tools appear on the Ribbon. 

2. Click the Options tab under Slicer tools on the 
Ribbon and select the style you want in the Slicer 
Styles group. 

The style is applied to the slicer. 

 Tip: You can also click the More button in the 
Slicer Styles group to view more styles. 

Delete a slicer 
If you no longer want to filter PivotTable data, you can 
remove the slicer completely. 

1. Click the slicer and press <Delete>. 

The slicer no longer appears in the worksheet. 

 Other Ways to Delete a Slicer: 
Right-click the slicer, and then select Remove 
<Name of slicer> from the contextual menu. 

Figure 10-19: Anatomy of a slicer. 

Working with PivotTables 

Selected 
buttons 
indicate 
items 
included in 
the filter. 

Clear all 
filters. 

Name of the field being 
used to filter data. 

Click and 
drag the 
textured area 
of a border to 
resize the 
slicer. 

Click and drag 
the border to 
move a slicer. 
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Sharing Slicers Between 
PivotTables 
If you’re working with a workbook that has several 
different PivotTables, it’s likely that you’ll want to apply 
the same filter to other PivotTables. This lesson shows 
you how to share slicers between PivotTables in a 
workbook. 

Apply a slicer to another PivotTable 
If you want to use a slicer in another PivotTable, you have 
to make the slicer available to that PivotTable. 

1. Click the slicer that you want to share in another 
PivotTable. 

The Slicer Tools appear on the Ribbon. 

2. Click the Options tab under Slicer Tools on the 
Ribbon and click the PivotTable Connections 
button. 

The PivotTable Connections dialog box appears. 
Other PivotTables you can share the slicer with are 
listed.  

3. Click the check boxes of the PivotTables in which 
you want the slicer to be available.  

4. Click OK. 

The slicer is now applied to the selected 
PivotTable(s). 

 Exercise 

• Exercise File:  Slicers2.xlsx, Sheet2 
• Exercise: Apply the Destination slicer from PivotTable 1 

to PivotTable 2. 

Figure 10-20: The PivotTable connections dialog box. 

Working with PivotTables 

Click the check 
box of the 
other pivot 
table to which 
you want to 
apply a slicer. 


